Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
VMware View Client Issue
25-02-2014, 06:45 PM,
#1
VMware View Client Issue
Hi Guys

Trying to get the VMware View Client working on build RPi-TC_ARMv6j_R4 but getting nowhere quickly. I can hit the connection servers, authenticate and see the available pools but as soon as it tries to connect to the relevant desktop in the pool the client just closes and disappears. Anybody out there seen the same symptoms?

Also I am getting cert errors even though I have a valid Cert from a trusted CA and I have tested this from the company LAN behind a proxy and from an DSL connection using NO proxy.

Any help would be appreciated.
Reply
25-02-2014, 10:32 PM,
#2
RE: VMware View Client Issue
I'm getting the same issue, and have posted it sometime back with no replys
Reply
26-02-2014, 01:28 PM,
#3
RE: VMware View Client Issue
Ok, so the SSL cert issue has been resolved now and I am not getting the prompts for invalid cert. BUT now getting a step further and a new error on connecting to the VDI desktop.

"Could not establish tunnel connection"
Reply
26-02-2014, 04:43 PM,
#4
RE: VMware View Client Issue
Are you trying to connect using the [IP or FQDN] of the [security server, or connection server]?
Reply
26-02-2014, 08:46 PM,
#5
RE: VMware View Client Issue
(26-02-2014, 04:43 PM)ben9035 Wrote: Are you trying to connect using the [IP or FQDN] of the [security server, or connection server]?

I am using the FQDN of the security server which is configured on the published cert. Using the FQDN of the connection server is producing similar results as to using the security server FQDN.

What I have noticed is that after authentication and the entitled pools is listed, once you try and connect to the pool the CPU of the Pi goes straight to 100% and after a while (15sec)the client either closes and disappears or I get the error writing to http tunnel failure
Reply
07-03-2014, 12:37 AM,
#6
RE: VMware View Client Issue
Same problem here. Have you been able to work arround it?
Reply
07-03-2014, 05:41 PM,
#7
RE: VMware View Client Issue
Sorry, I just your response. I was able to fix this issue on internal traffic.

First, under the view configuration administration page, make sure that your security server properties are pointed to the external ip and URL. Next, make sure that the connection server itself is pointed to the internal ip and FQDN of the connection. VMware and I went back and forth on this, and this HAS to be how its setup.

Next, you'll have to connect to the connection server, not the security server for internal use Pis, and the security server for any trying to connect remotely.

In addition, the 100% cpu usage seems to actually stem from the mouse, not anything to do with the VMware client itself. What I did to circumvent the issue was add

usbhid.mousepoll=10

to the end of the /boot/cmdline.txt file (make sure to put a space after the last bit in the file, or it won't read it properly.

In addition to all that, I then booted into the admin module of this distro, by pressing SHIFT+K during the boot video, and entering LOL for the password.

This point forward, do exactly what I tell you, because I jacked up a few instances of this and had to start over.

open 'Autostart Application' file on desktop.

Comment out the line that starts with @pcmanfm --desktop
Comment out the line that starts with @leafpad (unless you WANT the readme file popping up)
Comment out the line that starts with @x11vnc
Comment out the line that starts with @/home/rpitc

I added the line

@vmware-view

right before the #####s at the bottom of the section that says 'Add your autostart appz below'

By doing this, I have removed the actual GUI of the desktop, while still booting into the desktop, and enabling the VMWare client to autostart.

You retain the ability to right click anywhere, and get the same menu as before, but the CPU utilization is roughly 30% less (according to htop) than it was prior.

After all this, and a reboot, the Pi now boots straight into the VMware client, so my basic users can use it almost like their previous Windows client, and the CPU rarely hits 80-90%.

I'm glad to entertain questions or comments if you all need any help. The steps above are quite invasive to the distro and took me a while to figure out, so I've probably seen the problem you're having if you try the above and it doesn't work.
Reply
10-03-2014, 08:04 PM,
#8
RE: VMware View Client Issue
(07-03-2014, 05:41 PM)ben9035 Wrote: Sorry, I just your response. I was able to fix this issue on internal traffic.

First, under the view configuration administration page, make sure that your security server properties are pointed to the external ip and URL. Next, make sure that the connection server itself is pointed to the internal ip and FQDN of the connection. VMware and I went back and forth on this, and this HAS to be how its setup.

Next, you'll have to connect to the connection server, not the security server for internal use Pis, and the security server for any trying to connect remotely.

In addition, the 100% cpu usage seems to actually stem from the mouse, not anything to do with the VMware client itself. What I did to circumvent the issue was add

usbhid.mousepoll=10

to the end of the /boot/cmdline.txt file (make sure to put a space after the last bit in the file, or it won't read it properly.

In addition to all that, I then booted into the admin module of this distro, by pressing SHIFT+K during the boot video, and entering LOL for the password.

This point forward, do exactly what I tell you, because I jacked up a few instances of this and had to start over.

open 'Autostart Application' file on desktop.

Comment out the line that starts with @pcmanfm --desktop
Comment out the line that starts with @leafpad (unless you WANT the readme file popping up)
Comment out the line that starts with @x11vnc
Comment out the line that starts with @/home/rpitc

I added the line

@vmware-view

right before the #####s at the bottom of the section that says 'Add your autostart appz below'

By doing this, I have removed the actual GUI of the desktop, while still booting into the desktop, and enabling the VMWare client to autostart.

You retain the ability to right click anywhere, and get the same menu as before, but the CPU utilization is roughly 30% less (according to htop) than it was prior.

After all this, and a reboot, the Pi now boots straight into the VMware client, so my basic users can use it almost like their previous Windows client, and the CPU rarely hits 80-90%.

I'm glad to entertain questions or comments if you all need any help. The steps above are quite invasive to the distro and took me a while to figure out, so I've probably seen the problem you're having if you try the above and it doesn't work.

Thank you Ben for the Tips.
I still have the same issue, when I try to connect to the VM machine on my pool it closes my connection without any error.
I was able to go to View Configuration settings (Connection Server) and I do have the Use Secure Tunnel connection to desktop as external URL configured and Blast Secure gateway also enabled and configured.
I do not have a security server configured.
In local mode settings for my connection server I have "Use Secure Tunnel Connection for Local Mode Operations" enabled, "Use SSL for Local Mode Operations" enabled and "Use SSL when provisioning desktops in Local Mode" enabled.

Do you have any other configuration that I might be missing?
Reply
10-03-2014, 08:31 PM,
#9
RE: VMware View Client Issue
Oh, local mode (to my understanding) is not supported by this release. I've only gotten RDP to work on a regular basis. PCOiP will pretend like its working, then close the connection without error.
Reply
04-04-2014, 10:40 AM,
#10
RE: VMware View Client Issue
Hi i have the same problem when i try to connect to connection server (v5.2).
I'm not using pcoip, i don't have any security server.
On the events tab of vmware view connection server i see request from the client but nothing more.
From the thin client i can contact the connection server, login, see my desktop pools but after that it crash.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)