Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Static IP and Screen Blanking
06-03-2015, 02:09 PM, (This post was last modified: 11-03-2015, 12:47 PM by Gary Round.)
#1
Static IP and Screen Blanking
Hello and apologies in advance for these very basic questions.

I have successfully installed the latest version of the image onto a new RPi2 and have been able to successfully use it to connect to citrix environments ... it's a good result and we are all very encouraged by it.

I do have an alternative purpose I need the RPi2 for and am trying to utilise the RPiTC image to acheive this.

I need to put a static IP on it to make it easy to manage remotely and I want to use it to run a slideshow from iceweasel.

The slideshow is easy to set up with an add on but i can't figure out how to stop the screen from blanking. I have tried a number of ideas from articles that talk about modifiying such things as ~/.xinit or config files in /etc/kbd/ ... and a number of other similar suggestions none of which seem to be applicable to this image. Any suggestions on this would be much appreciated as would any suggestions for creating the static IP ... I have tried creating the /etc/network/interfaces but this only appears to suuceed in stopping Eth1 from even starting.

I am not paticularly adept at linux and am happy for someone to tell me I am stupid if that comes with some nice simple steps to fix it.

Genuinely any thoughts appreciated.

Regards
Gary.

[Update]

Well ... so far the static IP is alluding me but having solved the issue of x11vnc locking me out each time the viewer was disconnected and with the current IP available as a screen display on boot up this is less of an issue.

What I did stumble across was using the 'XScreensaver' package to manage the screen blanking.

I found this article in the official forum pages:
http://www.raspberrypi.org/forums/viewto...66&t=18200

The section that helped me was:

by tleland » Tue Feb 19, 2013 4:08 pm
Only way I've been able to fix this issue is install xscreensaver. To install you need "sudo apt-get install xscreensaver" . In the gui you will now have the "screensaver" option under preferences. Here you can disable the blank screen. Let me know if this makes sense and helps!


Hopefully that helps someone else stumbling along as a new RPi explorer.
Reply
16-03-2015, 06:35 PM,
#2
RE: Static IP and Screen Blanking
(06-03-2015, 02:09 PM)Gary Round Wrote: Hello and apologies in advance for these very basic questions.

I have successfully installed the latest version of the image onto a new RPi2 and have been able to successfully use it to connect to citrix environments ... it's a good result and we are all very encouraged by it.

I do have an alternative purpose I need the RPi2 for and am trying to utilise the RPiTC image to acheive this.

I need to put a static IP on it to make it easy to manage remotely and I want to use it to run a slideshow from iceweasel.

The slideshow is easy to set up with an add on but i can't figure out how to stop the screen from blanking. I have tried a number of ideas from articles that talk about modifiying such things as ~/.xinit or config files in /etc/kbd/ ... and a number of other similar suggestions none of which seem to be applicable to this image. Any suggestions on this would be much appreciated as would any suggestions for creating the static IP ... I have tried creating the /etc/network/interfaces but this only appears to suuceed in stopping Eth1 from even starting.

I am not paticularly adept at linux and am happy for someone to tell me I am stupid if that comes with some nice simple steps to fix it.

Genuinely any thoughts appreciated.

Regards
Gary.

[Update]

Well ... so far the static IP is alluding me but having solved the issue of x11vnc locking me out each time the viewer was disconnected and with the current IP available as a screen display on boot up this is less of an issue.

What I did stumble across was using the 'XScreensaver' package to manage the screen blanking.

I found this article in the official forum pages:
http://www.raspberrypi.org/forums/viewto...66&t=18200

The section that helped me was:

by tleland » Tue Feb 19, 2013 4:08 pm
Only way I've been able to fix this issue is install xscreensaver. To install you need "sudo apt-get install xscreensaver" . In the gui you will now have the "screensaver" option under preferences. Here you can disable the blank screen. Let me know if this makes sense and helps!


Hopefully that helps someone else stumbling along as a new RPi explorer.

I would wait for the build to get out of beta. I've had problems getting wifi working. Have you tried settting it in /etc/network/interfaces using this but with your values? I would but remoted into work right now.

auto eth0
iface eth0 inet static
address 192.0.2.7
netmask 255.255.255.0
gateway 192.0.2.254
dns-nameservers 8.8.8.8

I ended up setting assigning the address in my router dhcp table.
Reply
16-03-2015, 09:23 PM,
#3
RE: Static IP and Screen Blanking
I used to use the /etc/network/interfaces file as well to set my static IP but I've noticed that this new version of rpitc has the interfaces file empty?

Not sure where to put the static settings now. Admin or DaWest...can you comment please on where to set the Static IP?
Reply
23-03-2015, 10:56 AM,
#4
RE: Static IP and Screen Blanking
(16-03-2015, 06:35 PM)blu3suede Wrote:
(06-03-2015, 02:09 PM)Gary Round Wrote: Hello and apologies in advance for these very basic questions.

I have successfully installed the latest version of the image onto a new RPi2 and have been able to successfully use it to connect to citrix environments ... it's a good result and we are all very encouraged by it.

I do have an alternative purpose I need the RPi2 for and am trying to utilise the RPiTC image to acheive this.

I need to put a static IP on it to make it easy to manage remotely and I want to use it to run a slideshow from iceweasel.

The slideshow is easy to set up with an add on but i can't figure out how to stop the screen from blanking. I have tried a number of ideas from articles that talk about modifiying such things as ~/.xinit or config files in /etc/kbd/ ... and a number of other similar suggestions none of which seem to be applicable to this image. Any suggestions on this would be much appreciated as would any suggestions for creating the static IP ... I have tried creating the /etc/network/interfaces but this only appears to suuceed in stopping Eth1 from even starting.

I am not paticularly adept at linux and am happy for someone to tell me I am stupid if that comes with some nice simple steps to fix it.

Genuinely any thoughts appreciated.

Regards
Gary.

[Update]

Well ... so far the static IP is alluding me but having solved the issue of x11vnc locking me out each time the viewer was disconnected and with the current IP available as a screen display on boot up this is less of an issue.

What I did stumble across was using the 'XScreensaver' package to manage the screen blanking.

I found this article in the official forum pages:
http://www.raspberrypi.org/forums/viewto...66&t=18200

The section that helped me was:

by tleland » Tue Feb 19, 2013 4:08 pm
Only way I've been able to fix this issue is install xscreensaver. To install you need "sudo apt-get install xscreensaver" . In the gui you will now have the "screensaver" option under preferences. Here you can disable the blank screen. Let me know if this makes sense and helps!


Hopefully that helps someone else stumbling along as a new RPi explorer.

I would wait for the build to get out of beta. I've had problems getting wifi working. Have you tried settting it in /etc/network/interfaces using this but with your values? I would but remoted into work right now.

auto eth0
iface eth0 inet static
address 192.0.2.7
netmask 255.255.255.0
gateway 192.0.2.254
dns-nameservers 8.8.8.8

I ended up setting assigning the address in my router dhcp table.

Thanks for reading my ramblings :-)

I did actually try this and it seems to stop the NIC from getting any address at all... I suspect it will get ironed out ... For now it's not mega urgent as the IP is for all practical purposes static thanks to little competition on the DHCP range.

Cheers
Gary.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)