Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
RPi-TC 2 r 1.4 know issues/bug and next feature
17-07-2015, 09:46 AM,
#1
RPi-TC 2 r 1.4 know issues/bug and next feature
Know issues:
- Problem with audio still persist. I'll test audio redirection with an external audio card.
- with safe mode overclock all seem to be a bit laggy... (maybe is just me...)
Reply
20-07-2015, 07:21 PM,
#2
RE: RPi-TC 2 r 1.4 know issues/bug and next feature
Is it just me or do the ports (eth and usb) intermittently syop working on the latest build?
Reply
21-07-2015, 06:33 PM,
#3
RE: RPi-TC 2 r 1.4 know issues/bug and next feature
I ran into the following with Citrix Receiver

"Dynamic Module 'libproxy.so' could not be loaded (null)"

looks like libcurl.so.4 is missing

I did this
Code:
apt-get install libcurl4-gnutls-dev

then one of these

Code:
ln /usr/lib/arm-linux-gnueabihf/libcurl.so /usr/lib/arm-linux-gnueabihf/libcurl.so.4


seems to work now
Reply
23-07-2015, 04:42 AM,
#4
RE: RPi-TC 2 r 1.4 know issues/bug and next feature
Hello, would you consider using a more recent build of FreeRDP in your next release?

I rebuilt xfreerdp on rpitc with the latest master from Github (https://github.com/FreeRDP/FreeRDP), taking it to version 1.2.1-dev and there are probably many improvements and bug fixes, but one on particular was important for me --

The load-balance-info command line option tells a Windows Server 2012+ Remote Desktop Services (RDS) server farm which collection you are attempting to connect to. It then redirects you to the IP of the correct IP of the VM you have been assigned.

With the current version of xfreerdp, RDP redirection is broken so you cannot connect at all to a Windows Server 2012 or 2012 R2 farm.

Unfortunately, DirectFB client for FreeRDP is no longer maintained and includes a warning that it will probably not compile. Perhaps you could build dFreeRDP from the older version for those who need it, and XFreeRDP from the github master to get the bugfixes and updates?
Reply
28-07-2015, 04:59 PM,
#5
RE: RPi-TC 2 r 1.4 know issues/bug and next feature
(21-07-2015, 06:33 PM)Matt Meija Wrote: I ran into the following with Citrix Receiver

"Dynamic Module 'libproxy.so' could not be loaded (null)"

looks like libcurl.so.4 is missing

I did this
Code:
apt-get install libcurl4-gnutls-dev

then one of these

Code:
ln /usr/lib/arm-linux-gnueabihf/libcurl.so /usr/lib/arm-linux-gnueabihf/libcurl.so.4


seems to work now

that did the trick for launching receiver sessions via iceweasel.
Reply
29-07-2015, 08:49 AM,
#6
RE: RPi-TC 2 r 1.4 know issues/bug and next feature
As I could not see my ip address, I adapted the script used by conky as follows:
the script are located at : /opt/scripts/ipaddress.sh

change the line :
echo $(/sbin/ifconfig $(/sbin/route|grep default|awk '{print $8}')|grep 'inet addr'|awk -F: '{print $2}'|awk '{print $1}')

with this one :
echo $(/sbin/ifconfig $(/sbin/route|grep default|awk '{print $8}')|grep 'inet adr'|awk -F: '{print $2}'|awk '{print $1}')

And the IP address appears again Smile
Reply
29-07-2015, 04:22 PM,
#7
RE: RPi-TC 2 r 1.4 know issues/bug and next feature
The VNCServer password changer can be changed by anyone that goes to RPi-TC Config. I think this section needs to require the previous used password or require admin rights, which will not allow just anyone to change the VNCServer password.
Reply
24-08-2015, 08:33 PM, (This post was last modified: 24-08-2015, 08:43 PM by Arjen Furster.)
#8
RE: RPi-TC 2 r 1.4 know issues/bug and next feature
(21-07-2015, 06:33 PM)Matt Meija Wrote: I ran into the following with Citrix Receiver

"Dynamic Module 'libproxy.so' could not be loaded (null)"

looks like libcurl.so.4 is missing

I did this
Code:
apt-get install libcurl4-gnutls-dev

then one of these

Code:
ln /usr/lib/arm-linux-gnueabihf/libcurl.so /usr/lib/arm-linux-gnueabihf/libcurl.so.4


seems to work now

Hy, I was able to get Citrix Receiver working... After running the above commands (with sudo in front of it) and after first running 'sudo apt-get update' I was able to get the package.

Also you have to enter the whole line "ln /usr/lib/arm-linux-gnueabihf/libcurl.so /usr/lib/arm-linux-gnueabihf/libcurl.so.4" and not one of them.

For Google: the exact error message where this is the solution for: "Cannot load dynamic module: "libproxy.so" (null)" Quit
Reply
31-08-2015, 10:20 AM,
#9
RE: RPi-TC 2 r 1.4 know issues/bug and next feature
debian official repository now have new libcacard packages and latest spice-gtk version using it (0.29-1), and is also available for armhf without problem (before was blocked by spice server, not really required):
https://packages.debian.org/source/sid/spice-gtk
I think is good use official packages instead.
virt-viewer instead is not updated and require a small change for enable spice for armhf and use the new upstream version instead
Reply
04-09-2015, 10:57 AM,
#10
RE: RPi-TC 2 r 1.4 know issues/bug and next feature
Hi I'm still receiving freezing issues with 1.4
Everything just freezes and you're unable to move anything and a hard reboot is the only solution.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)