Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
RPiTC2 beta 1.99 out! UPDATE -> NEW image beta3
30-11-2015, 10:48 AM, (This post was last modified: 30-11-2015, 10:48 AM by admin.)
#11
RE: RPiTC2 beta 1.99 out!
(30-11-2015, 10:29 AM)admin Wrote: Maybe just a link can solve the problem:
cd /usr/lib/vmware/
ln -s libssl.so.1.0.2 libssl.so.1.0.1
ln -s libcrypto.so.1.0.2 libcrypto.so.1.0.1

Confirmed, its working now. VMWare Horizon package updated for RPiTC Builder
Reply
30-11-2015, 10:48 AM,
#12
RE: RPiTC2 beta 1.99 out!
(30-11-2015, 10:29 AM)admin Wrote: Seem that Horizon is looking for libcrypto.so.1.0.1 (and maybe also for libssl.so.1.0.1) but in the /usr/lib/vmware/ folder the libs are 1.0.2.
Maybe just a link can solve the problem:
cd /usr/lib/vmware/
ln -s libssl.so.1.0.2 libssl.so.1.0.1
ln -s libcrypto.so.1.0.2 libcrypto.so.1.0.1

Right, it's working now!
Reply
01-12-2015, 08:51 AM,
#13
RE: RPiTC2 beta 1.99 out!
(30-11-2015, 10:29 AM)admin Wrote:
(29-11-2015, 01:55 PM)palto42 Wrote: I've sent you a PM with a download link.

Thanks.
I've take a look and i've found something here:
readlink("/proc/self/exe", "/usr/bin/vmware-remotemks", 2048) = 25
geteuid32() = 1000
futex(0x76af60ac, FUTEX_WAKE_PRIVATE, 2147483647) = 0
open("/usr/bin/libcrypto.so.1.0.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
open("/usr/bin/libdir/lib/libcrypto.so.1.0.1/libcrypto.so.1.0.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
open("/usr/lib/vmware/lib/libcrypto.so.1.0.1-i386/libcrypto.so.1.0.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
open("/usr/lib/vmware/lib/libcrypto.so.1.0.1/libcrypto.so.1.0.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
open("/usr/lib/vmware/lib/libcrypto.so.1.0.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
open("/usr/lib/vmware/libcrypto.so.1.0.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
write(2, "SSLLoadSharedLibraries: Failed to load OpenSSL libraries. libdir is /usr/lib/vmware\n", 84) = 84
gettimeofday({1448719988, 58481}, NULL) = 0
write(6, "2015-11-28T15:13:08.058+01:00| main| E100: PANIC: SSLLoadSharedLibraries: Failed to load OpenSSL libraries. libdir is /usr/lib/vmware\n", 134) = 134


Seem that Horizon is looking for libcrypto.so.1.0.1 (and maybe also for libssl.so.1.0.1) but in the /usr/lib/vmware/ folder the libs are 1.0.2.
Maybe just a link can solve the problem:
cd /usr/lib/vmware/
ln -s libssl.so.1.0.2 libssl.so.1.0.1
ln -s libcrypto.so.1.0.2 libcrypto.so.1.0.1

Thanks for your help, this solved the issue and I could connect to the VMware Horizon server Smile

One thing which is still not fully working is the audio, the microphone doesn't work at all. In PAVC VMware is not shown as recording device, even if I open a recording in the VM session. I had a similar issue in the past on Ubuntu, but in current releases (since about 14.04) it works and I don't know what the issue was.
I used a Logitech USB headset for audio in/out and also tried a Sennheiser USB headset. Both work fine on my Ubuntu 14.04 and 15.10.

With the Sennheiser I observed another strange issue not related to VMware. After a short while the audio started to get unusable because it was drown out by noise. If I stopped playback, the noise also stopped. I could reproduce this issue with Youtube playback in local Iceweasel and with audio playback in VMware. With the Logitech I didn't have it (yet?), will test a bit more.
If I switched the playback to the audio jack, it was w/o noise. But I could not switch back, even if I unplugged/re-plugged the Sennheiser.
Reply
02-12-2015, 05:07 AM,
#14
RE: RPiTC2 beta 1.99 out!
how can i remove the lower dock ? ive done the reboot but it still there.
Reply
02-12-2015, 10:33 AM,
#15
RE: RPiTC2 beta 1.99 out!
(02-12-2015, 05:07 AM)fydo pete Wrote: how can i remove the lower dock ? ive done the reboot but it still there.

lower dock? there is just the docky dock on left and right sides.
Is the dock an xfce4 menu? If yes go in Settings, Session and Startup, Session and remove the xfce4-panel program
Reply
03-12-2015, 01:56 PM,
#16
RE: RPiTC2 beta 1.99 out!
(02-12-2015, 10:33 AM)admin Wrote:
(02-12-2015, 05:07 AM)fydo pete Wrote: how can i remove the lower dock ? ive done the reboot but it still there.

lower dock? there is just the docky dock on left and right sides.
Is the dock an xfce4 menu? If yes go in Settings, Session and Startup, Session and remove the xfce4-panel program

i was able to remove it, but after a few reboot it came back.. how can i remove it permanently ?
Reply
03-12-2015, 01:59 PM, (This post was last modified: 03-12-2015, 02:23 PM by admin.)
#17
RE: RPiTC2 beta 1.99 out!
Did you delete some file or folder in the /home/rpitc/ folder?
I've made about 300 autoreboot via script to check the OS stability and all was fine.
Reply
06-12-2015, 09:16 AM, (This post was last modified: 06-12-2015, 09:16 AM by budder prince.)
#18
RE: RPiTC2 beta 1.99 out!
i tried the horizon client, and i think i have to configure vmwareusbd because keyboard/mouse not working, i read the vmwareusbd is running by default, how do i configure this? or should i try with virtualhere?

also i noticed 100% cpu usage and the frames/s showed in the horizon client are a bit low, maybe stupid question but isnt gpu acc possible for this? (i think dfreerdp had it and it worked nice, yeah ik two different things)
Reply
08-12-2015, 03:37 PM, (This post was last modified: 08-12-2015, 04:00 PM by Maik20.)
#19
RE: RPiTC2 beta 1.99 out!
What is the username and passwort?

I have copied the image to the sd-card and bootet the raspberry. I need to change some settings so my screen wont work. So i tried to login with ssh. But root/raspberry wont work!

Sorry i have found it: It is root/root

Maybe you can add "hdmi_safe=1" to your boot config. Because some older displays wont work with the default settings. I had to change it to get it to work.

One more Question: What is the difference between the xfreerdp git and debian version? Can i install both?
Reply
08-12-2015, 04:23 PM,
#20
RE: RPiTC2 beta 1.99 out!
(08-12-2015, 03:37 PM)Maik20 Wrote: One more Question: What is the difference between the xfreerdp git and debian version? Can i install both?

xfreerdp is the standard Debian version: 1.1.0~git20140921.1.440916e+dfsg1-5 (1 year old)
xfreerdp_git is the version rebuilded from official FreeRDP git repo (new version with more options fixes etc.)

You can install both versions, config files: xfreerdp.config and xfreerdp.server are shared.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)