Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
No sound through 3.5mm jack
08-03-2017, 10:15 AM,
#11
RE: No sound through 3.5mm jack
(07-03-2017, 01:32 PM)Georg Getreuer Wrote: I have the same issues with the 3_1.12 release. With the previous it was possible to have good sound (at least for sound-files) with /sound:sys:alsa and run xfreerdp as root. Even video did work acceptable (what I do not need). The whole line looked like:
sudo xfreerdp_git TServer /cert-ignore /f /sound:sys:alsa +fonts +aero /smartcard +drives +clipboard /rfx /smart-sizing /gdi:sw /jpeg /jpeg-quality:100 /codec-cache:jpeg +async-update

With the 3_1.12 release sound is buggy.

I've rebuilded the xfreerdp client from the git repo right now, could you please try it? (http://dl.armtc.net/RPi-TC/packages/xfreerdp_LATEST)
If you want roll back to a good xfreerdp version you can download it here:
http://dl.armtc.net/RPi-TC/packages/
I think the previous 3.11 was this one:
http://dl.armtc.net/RPi-TC/packages/xfreerdp_20162711
Reply
08-03-2017, 11:16 AM,
#12
RE: No sound through 3.5mm jack
I tried your dfreerdp suggestion:

dfreerdp --no-tls --no-nla -f -g 1920x1080 --fonts -x 0x80 -x l --disable-full-window-drag --composition --gdi hw --plugin rdpsnd --data alsa --data disk:usbdisk:/media/ -- server.domain.lan

I see some plugin-problems but I can see a 'connected to' line, that looks ok. But after that:

recv: Connection reset by peer
Error: protocol security negotiation failure

So I turned to my RDS-server, and I seems the option is selected "allow connections only from computers running remote desktop with network level authentication (recommended)"

And I see the switch '--no-nla' in your suggestion. But when I leave that switch out:

dfreerdp --no-tls -f -g 1920x1080 --fonts -x 0x80 -x l --disable-full-window-drag --composition --gdi hw --plugin rdpsnd --data alsa --data disk:usbdisk:/media/ -- server.domain.lan

I am asked to trust the certificate, which i do.

SSl_read: failure in SSL library (protocol error?)
Authentication failur, check credentials.
If credentials are valid, the NTLMSSP implementation may be to blame.

So it might be a NLA problem.

Now I'm going to reinstall 3.12 and try the latest Xfreerdp, see if that is the solution.
Reply
08-03-2017, 11:48 AM,
#13
RE: No sound through 3.5mm jack
I downloaded http://dl.armtc.net/RPi-TC/packages/xfreerdp_LATEST

Do I have to use the builder to install this latest version? When I go to the tab "Cust." I can't select the xfreerdp_latest file.
Reply
08-03-2017, 12:40 PM,
#14
RE: No sound through 3.5mm jack
Perfect!
Sound works again with the xfreerdp_LATEST.
So everything is fine with:
sudo xfreerdp_git 'Server /cert-ignore /f /soundConfusedys:alsa +fonts +aero /smartcard +drives +clipboard /rfx /smart-sizing /gdiConfusedw /jpeg /jpeg-quality:100 /codec-cache:jpeg +async-update

I try to test to run it as a normal user later on.

@Henk You should reinstall xfreerdp_git with the RPITC-Builder
Reply
08-03-2017, 12:49 PM,
#15
RE: No sound through 3.5mm jack
(08-03-2017, 11:16 AM)Henk Jaspers Wrote: I tried your dfreerdp suggestion:

dfreerdp --no-tls --no-nla -f -g 1920x1080 --fonts -x 0x80 -x l --disable-full-window-drag --composition --gdi hw --plugin rdpsnd --data alsa --data disk:usbdisk:/media/ -- server.domain.lan

I see some plugin-problems but I can see a 'connected to' line, that looks ok. But after that:

recv: Connection reset by peer
Error: protocol security negotiation failure

So I turned to my RDS-server, and I seems the option is selected "allow connections only from computers running remote desktop with network level authentication (recommended)"

And I see the switch '--no-nla' in your suggestion. But when I leave that switch out:

dfreerdp --no-tls -f -g 1920x1080 --fonts -x 0x80 -x l --disable-full-window-drag --composition --gdi hw --plugin rdpsnd --data alsa --data disk:usbdisk:/media/ -- server.domain.lan

I am asked to trust the certificate, which i do.

SSl_read: failure in SSL library (protocol error?)
Authentication failur, check credentials.
If credentials are valid, the NTLMSSP implementation may be to blame.

So it might be a NLA problem.

Now I'm going to reinstall 3.12 and try the latest Xfreerdp, see if that is the solution.

You can try to pass the user/pass to the dfreerdp cmdline, just to test if the connection is working. Add:
-u username -p password -d domain
at the beginning of your cmdline
Reply
08-03-2017, 12:52 PM,
#16
RE: No sound through 3.5mm jack
(08-03-2017, 11:48 AM)Henk Jaspers Wrote: I downloaded http://dl.armtc.net/RPi-TC/packages/xfreerdp_LATEST

Do I have to use the builder to install this latest version? When I go to the tab "Cust." I can't select the xfreerdp_latest file.

Download the xfreerdp_LATEST and overwrite the old one by cping in /usr/bin/ folder and add exec flag (as root):

cp xfreerdp_LATEST /usr/bin/xfreerdp_git
chmod +x /usr/bin/xfreerdp_git
Reply
08-03-2017, 12:53 PM,
#17
RE: No sound through 3.5mm jack
(08-03-2017, 12:40 PM)Georg Getreuer Wrote: Perfect!
Sound works again with the xfreerdp_LATEST.
So everything is fine with:
sudo xfreerdp_git 'Server /cert-ignore /f /sound:sys:alsa +fonts +aero /smartcard +drives +clipboard /rfx /smart-sizing /gdi:sw /jpeg /jpeg-quality:100 /codec-cache:jpeg +async-update

I try to test to run it as a normal user later on.

@Henk You should reinstall xfreerdp_git with the RPITC-Builder

Ty for report back :)
Reply
08-03-2017, 01:14 PM,
#18
RE: No sound through 3.5mm jack
Thanks Georg,

In the RPiTC Builder, I selected only XFreeRDP (Git Rebuilded). After a bashme, i tried your example line.

But somehowe the syntax is wrong because every time I get some sort of --help output. Many lines of switches en examples.
So I tried to simplify the line.

Just: sudo xfreerdp_git /u:<username> /p:<password> /v:<server-address>

Now I was asked to trust the server, i did, and then 5 lines with [Error][com.freerdp.client.....] and then status error codes. When I add /cert-ignore it makes no difference. Maybe I installed incorrectly?

When I try your line again, again I get the --help lines.

Sorry for my inexperience with this.....
Reply
08-03-2017, 01:20 PM, (This post was last modified: 08-03-2017, 01:22 PM by admin.)
#19
RE: No sound through 3.5mm jack
when you see the --help lines means that there is a syntax error in your cmdline.
try this command:

xfreerdp_git SERVERIP /cert-ignore /f /sound:sys:alsa +fonts +aero /smartcard +drives +clipboard /rfx /smart-sizing /gdi:sw /jpeg /jpeg-quality:100 /codec-cache:jpeg +async-update

If your password contains special chars like ' or " or / this will break the xfreerdp cmdline parser
Reply
08-03-2017, 02:11 PM,
#20
RE: No sound through 3.5mm jack
Allright, I had not tried it yet with the IP addess from my server. So i copied the Xfreerdp_latest to /usr/bin/xfreerdp_git, I added the exec flag. Now I tried this line:

sudo xfreerdp_git 192.168.125.52 /cert-ignore /f /sound:sys:alsa +fonts +aero /smartcard +drives +clipboard /rfx /smart-sizing /gdi:sw /jpeg /jpeg-quality:100 /codec-cache:jpeg +async-update

After I press ENTER, the --help lines appear. So there is a syntax problem in this line.

Now I tried a slightly different line:

sudo xfreerdp_git /v:192.168.125.52 /u:<username> /cert-ignore /f /sound:sys:alsa +fonts +aero /smartcard +drives +clipboard /rfx /smart-sizing /gdi:sw /jpeg /jpeg-quality:100 /codec-cache:jpeg +async-update

Now I am asked for my password, so I type that and then finally succes! My remote desktop session starts!

I tried playing an MP3, and an underrun occurrd, the music stalls. When I use the RPiTC volume control and press mute two times the music returns. I tried adding ,latency=500 after /sound:sys:alsa but however the underrun errors are gone, the sound is crappy and stalls everytime.

I'll try some slightly different settings again, if I make any progress I will let you know.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)