ARMTC Forum

Full Version: Pulseaudio remote-viewer
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi everyone,

In another thread I talked about audio problems with my remote-viewers connections with spice. The message that it appears is the following:


(remote-viewer.555) Gspice-WARNING ** PulseAudio context failed connection refused

(remote-viewer.555) Gspice-WARNING ** pa_context_connect() failed: connection refused


Please any help about how to solve this? It's very important for me...

Thanks!!!
Please anyone knows how to configure pulseaudio in the raspberry????'
Hi manute71,

I don't use pulseaudio and I don't know how to use him but I'm gonna search and test this. I don't know if I can help you but if I found something I will give you an answer.

Good luck, I'm gonna search it right now.

I think your problem is in this file:

Code:
/etc/pulse/client.conf

Share the content of this file and maybe I can help you. If you find an answer don't forget to say how you resolve your problem. Big Grin
Thank you for your quick response Arag!
All the content of the file is commented. The question is that I have the following squema:

Raspberry (remote viewer with thinclient) <--> proxmox server <--> Windows 7 VM.
With this configuration, I don't have audio.

With this one:
Windows 7(remote viewer) <--> proxmox server <--> Windows 7 VM. With this one, I have.

So, tell me please what i should do? Thanks a million.
Hi manute71,

Try to ping your server with your Raspberry, maybe the connection is failed.

I don't really know how to resolved this problem but I'm gonna search if I can found something.

Good luck.
I don't use Pulseaudio either myself but here are some suggestions for you:

manute71, have you tried re-installing or upgrading pulseaudio on your Pi? I found this reference from Aug. 2014 regarding Spice and Sound (https://bbs.archlinux.org/viewtopic.php?id=186086):

Quote:It looks like the issue is due to an interface change between spice-gtk3 0.24-2 and 0.24-3. spice-gtk 0.24-3 changed the audio back-end from pulseaudio to gstreamer.

rpitc uses a newer version than 0.24-3 but maybe4 there is still a problem and a newer version will fix it? Just a guess.

Or perhaps this is an issue with the Spice Client on Arm...you may want to post this question on a Spice Forum or the Proxmox Forum or the Raspberry Pi forum (Do all three just to be safe) to see if someone on those forums has any reasons for this not working for you. The Pi Engineers and Foundation Staff are regulars on the Raspberry Pi forum.

The error you are getting is not showing up when I Google for it so it seems obscure at this time.

Sorry I can't be of more assistance.
I had this problem when I first tried using remote-viewer on RpiTC (like you I'm also using a Proxmox server with Win7). I solved it fairly simply by installing pulseaudio:
Code:
sudo apt-get install pulseaudio

(BTW this also fixes the same problem with virt-viewer compiled under raspbian on Rpi2 - I've not yet tried the new version of RpiTC for Rpi2).