ARMTC Forum

Full Version: Autostart rdesktop problem
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi,
i'm trying to autostart rdesktop at system startup.

i create /home/rpitc/.xinitrc

i add

Code:
rdesktop 192.168.1.100 -f -u testuser

when i reboot the rdesktop start correcty but afret some seconds it close itself...

any ideas or suggestion how to start rdesktop at the startup??

thanks
Hi ceriox,

I'm not all that familiar with using .xinitrc for startup scripts but if I'm not mistaken you have to be careful when using it for startup because when using .xinitrc you need to ensure your program you are calling which do not return or exit right away might cause issues with subsequent running programs. I'm not sure what's in your .xinitrc file since you did not post it but suffice it to say I don't think this is the way I would autostart rdesktop on rpitc.

Let's first make sure your rdesktop instruction is working in the first place. Have you taken your rdesktop line and used it in a terminal session to ensure it's working for you?

Once you've confirmed it's working then let's move on....

Looking around I can see that Gibbio is using .desktop shortcuts with instructions in them that run the scripts He needs. These are located in ~/.config/autostart/ folder. Edit one of these

Code:
nano killintro.desktop

And you can see in the Exec= line the script that He is having executed (in this case the killintro.sh script).

If you haven't already, create an .sh script with your rdesktop instructions in them. Create a new .desktop file and edit it to include the location of your rdesktop.sh script. Be sure to change the name and Comment so it's clear what this shortcut is doing.

Another option for you is to simply use the XFCE Session and Startup to start your script. Right click on your desktop...select 'Settings' and then select 'Session and Startup'. On the third tab you'll see 'Application Autostart'. Add a new startup and point to your rdesktop.sh script.

Reboot your computer and ensure your rdesktop connection works for you.

If you need to keep your rdesktop session always on try using a cron job to reconnect you in case the rdesktop session gets shutdown (not sure if this is a requirement for you or not but thought I would mention it in case it's useful for you).


Good Luck!