ARMTC Forum

Full Version: virt-viewer error
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
It seems virt-viewer is not correctly installed.

When you try to use it, it drops:
virt-viewer: error while loading shared libraries: libvirt.so.0: cannot open shared object file: No such file or directory.

I have used remote-viewer to make a spice connection.
i think i forgot some library around... ill check on spice sources
did you receive the same error when using spicy client?
Yes, libvirt0 is missing, please install it by: apt-get install libvirt0

Thanks
(17-11-2013, 07:24 PM)Gibbio Wrote: [ -> ]Yes, libvirt0 is missing, please install it by: apt-get install libvirt0

Thanks

Now I have the next error:
virt-viewer: /usr/lib/libvirt.so.0: version 'LIBVIRT_0.10.0' not found (required by virt-viewer). The version that comes is 0.9.12
i´ve rebuild all the spice package, please update it by apt-get update && apt-get upgrade