ARMTC Forum

Full Version: Playing sound on virtual machine makes freerdp to disconnect
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I'm having problems with analog sound. When virtual Windows 7 plays anything the connection disconnects. I'm using freerdp and normal alsa settings.

I've set audio output for analog instead of hdmi. This is what i have done:

1. sudo modprobe snd_bcm2835
2. sudo amixer cset numid=3 1

Instructions from here:
http://www.raspberrypi-spy.co.uk/2012/06...ound-test/

What to try next? I really would wanna hear some sound. Smile
ummm seem an audio dump on exec. Could you please run it from lxterminal and post the output?
Which command line you use to connect via xfreerdp? Alsa or Pulse? Try with "/soundConfusedys:alsa,latency:500"
I'm not the one that started the thread but i'm having the same issue, the difference is that i didn't change any sound parameter.

Here is the output that you asked for:

Code:
rpitc@rpitc-:~$ xfreerdp /v:X.X.X.X /size:800x600 /u:Administrator +compression /sound:sys:alsa,latency:500
loading channel rdpsnd
connected to X.X.X.X:3389
Password:
Unable to find a match for unix timezone: Etc/UTC
Warning rdpsnd_alsa_open_mixer (280): snd_mixer_attach failed
ALSA lib pcm_hw.c:1667:(_snd_pcm_hw_open) Invalid value for card
Warning rdpsnd_alsa_open (320): snd_pcm_open failed
xfreerdp: pcm.c:1250: snd_pcm_writei: Assertion `pcm' failed.
Aborted

Thanks