Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Greek characters and usb mount options
22-01-2016, 03:54 PM,
Greek characters and usb mount options

I have the following issues:

1) Greek characters in usb are not displayed correctly and the same goes when usb is redirected (using xfreerdp). Instead I see question marks (e.g ??????.txt)

2) usb is not mounted as R/W when redirected (it is mounted as r/w on the the pi though). I can see the contents but cannot create new file/copy/paste etc. I tried a solution I found on a post (add "uid=rpitc,guid=rpitc" in usbmount.conf) but didn't work.

I use a RPi-TC2 release 1.4

Any suggestions?

BTW great effort!!!!!!
25-01-2016, 10:44 AM, (This post was last modified: 25-01-2016, 10:44 AM by admin.)
RE: Greek characters and usb mount options
there is a good guide here for Greek :

But normally you have just to run:
sudo dpkg-reconfigure locales
and select your language (for Greek is el_GR.UTF-8 I think)

For the second question, please install the last 1.99 version and tell me if everything is working
25-01-2016, 12:24 PM, (This post was last modified: 25-01-2016, 12:48 PM by cvassiliou.)
RE: Greek characters and usb mount options
and thank you for your prompt response.

Please have a look in the attached photos.
I tried your suggestion but it didn't work.
Also, I used raspbian to see if there was a problem with the specific files and/or usb.
You will see that raspbian has no issues with greek characters. And both are using the UTF charmap. In fact I tried any locale that I thought it would be helpful with no luck.
In the rpiTC you can only see question marks.

See also the redirected usb using xfreerdp. You can see the same issue with the greek characters plus the inability to create files when using rpiTC (no such issue with raspbian).

I will check the 1.99 version and I will report back

Thank you!

(I had to hide some folders, sorry!!) Confused

Attached Files Thumbnail(s)
26-01-2016, 06:13 PM,
RE: Greek characters and usb mount options
Today I checked the 1.99 version.
I used the builder's default options and added xfreerdp, rdesktop, and cups.

(FYI: First thing that I noticed is that left mouse click does not give me option to edit xfeerdp.conf so i had to use the file manager to edit the file.)

As for the rest I have the same behavior:
1.Greek characters are not displayed correctly (I used dpkg-reconfigure locales to select UTF-8 but with no luck)
2.USB is redirected (xfreerdp) to server (windows-7 ultimate) but I cannot create file/folder

I am planning to run rpiTC in a project in my office with minimum requirements:
1. Greek characters
2. USB redirection as r/w
3. Printer redirection

Until now 2 out of 3 gives me headache.Angry Angry
Haven't tested printer yet

Any suggestions?
13-02-2016, 10:57 PM, (This post was last modified: 13-02-2016, 10:58 PM by barucha.)
RE: Greek characters and usb mount options
I have the same problem with Hebrew language. its was tested in 3 other thin client brands and its the same.
Its doesn't rasp problem, Its happens also from win CE thin client.
16-02-2016, 10:26 AM,
RE: Greek characters and usb mount options
I've cooked my RPi2 board... I'll try next days when a new board arrive

Forum Jump:

Users browsing this thread: 1 Guest(s)