Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Rdesktop doesn't autostart
11-08-2014, 04:03 PM,
#1
Rdesktop doesn't autostart
Hey everyone,

in the last 2 weeks I've been working on setting up the RaspberryPi as a thin client on Info-Displays (big screens in public areas to show Information to everyone). The clients open a RDP Session and execute Firefox on a Windows Server 2008 R2. Firefox shows it's homepage in fullscreen and that's it(there is a lot of animated Widgeds and lifetickers so i need good performance). Every Display (thin client) has their "own" windows user account amd password.
I like the lightweight setup of RPiTC (running R5) and the performance coming of it.
Anyways i had to make a few changes to the System to go with our security standards and to ease the configuration for my fellow coworkers on the Pis. I only have one Pi for testing purposes here in my lab. We are using Dell Wyse Thin Clients on the live-systems.
When i finally found the authors (new?) gpg-key and implemented it in my system i were able to update my packages and download new ones (like man-pages).
From there on i could complete my setup and everything was working just fine last week.
Today (Monday) I came back and my Rdesktop autostart doesn't work anymore. When i use the exact same command and parameters in LXTerminal it works just fine.
Code:
rdesktop -u User -p Password -d Domain -s "C:\Program Files (x86\Mozilla Firefox\firefox.exe -P "rpi"" -f -z -x m -b -m -P -D server.subdomain.domain.tld
When I comment the "Readme_Please.txt" line in the autostart file out, it won't show the readme on startup and vice versa. So my guess is it could be an issue with the time when the Raspberry tries to execute the command. Could i be right with my guess or am i absolutly wrong? I also don't know much about Unix and their bootprocess.
I'd be very happy if one of you guys could help me with my Issue, since I want to promote this project to be deployed in our environment .
Greetings,
Marc
Reply
12-08-2014, 02:24 PM, (This post was last modified: 12-08-2014, 02:32 PM by greavette.)
#2
RE: Rdesktop doesn't autostart
This does sound strange. I've tried your rdesktop instructions and I find no issues when I use them either. I don't have an answer for you on why but here are some suggestions that might help you figure out why.

First, turn off the video that plays when your rpitc starts. I do this by just renaming the video file in the rpitc folder. Use something like the following:
Code:
mv video.h264 bkup_video.h264

The move command used in this way is a rename command to the name of the file. When you want to rename it back go in reverse:
Code:
mv bkup_video.h264 video.h264

Now when you reboot your rpitc client watch the text that scrolls by for any error messages related to your rdesktop instruction.

Secondly, try keeping your instruction really simple. Just use the -u -p -d -z -f commands and remove the rest of the commands in your autostart file. If this works when you reboot slowly add back each additional command to each subsequent test.

Third thing for you to try is to put your rdesktop instruction in a script and see if any errors are written when you execute the script. Try something like this script which I've named rdesktop.sh. Assuming you have a folder called scripts:

cd /home/rpitc/scripts/
nano rdesktop.sh

Now paste in the following code:
Code:
#!/bin/bash
# Check if rdesktop is running
Logfile=/home/rpitc/scripts/scripts/rdesktop_Connect.log
if pgrep rdesktop > /dev/null
then
        echo "$(date "+%m%d%Y %T") : rdesktop is already running.  Existing this script" >> $Logfile
        exit 0
else
        echo "$(date "+%m%d%Y %T") : rdesktop has Stopped. Attempting to restart." >> $Logfile
        rdesktop -u user -p password -r sound:off -f -z -x m -b -m -P server >> $Logfile
        exit 0
fi

Now make the script executable using this
Code:
chmod +x rdesktop.sh

Then run the code in your terminal:
Code:
sh ./rdesktop.sh

If there is an error you will either see it in your terminal or in the logfile that gets created.
Reply
12-08-2014, 05:49 PM,
#3
RE: Rdesktop doesn't autostart
Hey greavette,

thank you very much for your answer.
Unfortunately I managed to corrupt the filesystem on my SD.
Since my R5-live and !!Backup!! are appearently broken, as in live boots with blackscreen and returns me to console after 2 min and backup does the same as written in first post (this all wasn't the case when the backup has been created), I formatted the SD on Windows and
Today i flashed the Hardfloat image (i was using the R5 with Berryboot before and tweaked a lot, properly a bit too much) and will try to keep things as simple as possible without Berryboot this time.
Reply
13-08-2014, 01:39 AM,
#4
RE: Rdesktop doesn't autostart
Keep me informed...always happy to hear how others have setup their office with rpitc.

I love using berryboot myself. In fact berryboot has just implemented a recent change that allows images to be retrieved from a file share. This will work very well for us as it will be very easy then to upgrade rpitc remotely with no one needed on site to replace SD cards.

One day when I get time I'll write up how I'm using this fantastic rpitc project in our small office.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)