Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Infinite booting loop, RPITC-X
19-10-2014, 02:20 AM,
#1
Infinite booting loop, RPITC-X
Hello,

I have tried repeatedly to use the new RpiTC-X image loaded October 17 on my raspberry pi, but it can never seem to boot past the loading video.

Also, during the video the screen repeatedly flashes to a steam of code and back again to the video, but it never finishes booting up.

Has anyone else experienced this? Does anyone know how to fix?
Reply
19-10-2014, 12:25 PM,
#2
RE: Infinite booting loop, RPITC-X
No problem here. Tried both on B and B+, with a couple of SD cards and everything I tried works fine. The useful ping command is missing, I had to issue: sudo apt-get install iputils-ping .The password is rpitc.
Reply
20-10-2014, 09:50 AM,
#3
RE: Infinite booting loop, RPITC-X
Oh Sad No ping, sorry, ill add it.
For the boot loop maybe is related to the new Overcloking parameters:
https://github.com/Gibbio/RPiTC-Kernel/b...ig.txt#L44
Try to comment out the overclokin lines or switch back to old config:
https://github.com/Gibbio/RPiTC-Kernel/b...config.txt
Reply
20-10-2014, 09:53 PM,
#4
RE: Infinite booting loop, RPITC-X
I tested the new RpiTC-X the whole day at the office. It's a very good work! Surely a lot of time has been poured into this project. A while ago I spent days trying to streamline and integrate the Raspbian image for thin client purposes, and my end result was not even close to this.
The missing ping command is a minor inconvenience but after a full day of testing on various RDP scenarios, I sadly found a real issue. The xfreerdp executable seems to be compiled from a broken version. If you don't touch mouse or keyboard, the freerdp window will close after a random delay (about 18-120 seconds) with the error "failed to check RDP file descriptor". The issue is influenced by the server behaviour. A session with Windows 2012R2 o Windows 8 will last several minutes, and it may avoid the issue entirely. A session to Windows 2008R2 terminal server will disconnect earlier. This is unrelated to keepalive parameters or GPO you can set on the terminal server. The session will always stay on when using rdesktop (or the standard Windows mstsc.exe client).

I found this freerdp bug while testing the Ubuntu 14.04 implementation, and it seems to be well known. See (as example) this post: https://github.com/FreeRDP/FreeRDP/issues/1202 . The github poster says that the fix is very simple (comment out a line of the source and recompile). This has not yet been integrated on the main freerdp repository, apparently.

Has someone experenced the same issue? Just open a plain RDP session to a Windows 2008R2 terminal server, take a coffee or answer a phone call, go back to the Raspberry: is the Freerdp window still open?

Freerdp supports a faster and more recent version of the RDP protocol and the RD gateway feature, so I would rather use it; but now I am forced to use rdesktop on RpiTC-X. Is it possible to have a patched (or earlier) version of the xfreerdp executable?
Reply
21-10-2014, 06:27 PM,
#5
RE: Infinite booting loop, RPITC-X
I traced the problem to one specific rpi unit, model b. I think it may actually be having hardware problems and the OS isn't the issue because 2 other rpi b+ units seem to work great so far. Great release!
Reply
21-10-2014, 07:28 PM,
#6
RE: Infinite booting loop, RPITC-X
seem that is related "only" to some 2008 versions. There is any log on the server side?
This happend also if you keep up a ping on the ts server?
Reply
23-10-2014, 10:54 AM,
#7
RE: Infinite booting loop, RPITC-X
I managed to make further tests.
I confirm that the issue is on Windows 2008 and 2008R2. I have many 2008 server still in production, unfortunately. There is no error listed on the server; the disconnection appears to be client-side. Pinging the server or changing the server RDP keepalive parameters does not solve the issue. I also discovered that the /f (fullscreen) option of the xfreerdp included on this release does not work. If I launch xfreerdp from command line, I see a short flash (the window appears to open and close again), but the command remains in execution (the shell is not released), and I need to terminate it with a ctrl+c.

There is no dock/taskbar: if I hit the iconify button on the xfreerdp window, I need to right click on the Raspberry PI desktop and select the Xfreerdp windows from the desktops/desktop1 menu item (thats still OK but not the best option).
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)