Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
VMWare View Client Issues
06-05-2015, 10:20 AM, (This post was last modified: 06-05-2015, 10:29 AM by alexp.)
VMWare View Client Issues

I've installed the "RPi-TC X" image (23rd Oct 2014) on my Pi model B. I'm trying to get the VMWare client working. Unfortunately I get an issue where after I login and see the pool of VMs I double-click one it starts but then drops out. I'm using RDP as I know PCoIP doesn't work. Different screen configs doesn't help either.

I've checked the logs under /usr/tmp/ and the last error is it trying to start "vmware-view-usb". Looking under /usr/bin it doesn't exist. I suspect there are some files missing on this image.

Are there any steps on how to get this installed correctly? Do I have to build it myself?

This post here helped: He seems to have found the file but I can't find it. There is "vmware-view-usbd" in /usr/lib/vmware/ but copying it to /usr/bin/ and renaming doesn't work either.


I've found a post here about how I might be able to get it to work:

Will try it later.
07-05-2015, 10:56 AM, (This post was last modified: 07-05-2015, 11:20 AM by alexp.)
RE: VMWare View Client Issues
I tired running the "vmware-usbarbitrator" and "vmware-view-usbd" but neither stay up. Also "vmware-view-usbd" had issues with not existing so tried linking it to but it still wouldn't stay up.

I then tried linking "vmware-view-usb" to "vmware-view-usbd" and managed to get it to go past this point. Now I've got issues when trying to RDP:

CredSSP: Initialize failed, do you have correct kerberos tgt initialized ?

I'm connecting to Windows 7 and 8.1 VMs. Could this be an NLA problem and are there any workarounds?


I've founds some docs here regarding VMWare view setup:

According to this you can redirect the RDP to use xfreeRDP which may support NLA? I'm hoping to try this later to see if it works.
08-05-2015, 06:33 PM,
RE: VMWare View Client Issues
I finally managed to get this working. Problem was by default it seems to use rdesktop so the trick was to redirect the RDP to xfreerdp. At the moment I run this from the terminal:

/usr/bin/vmware-view --rdpclient=xfreerdp --xfreerdpOptions="/cert-ignore"

I'll be adding these to the config file so that it won't need the parameters. Another issue I need to sort out is connecting to different machines. It appears to store the key in the known_hosts file based on the IP address. But for each one it uses so when you switch it complains about the key. For now I've added them all and comment out the ones I'm not using.

Forum Jump:

Users browsing this thread: 1 Guest(s)