Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Terminal session on startup
18-05-2015, 09:11 AM,
#1
Terminal session on startup
Hi,

I'm working on a way to automatic start a terminal session to our AS400 server when the PI boots, but for some reason nothing happens at startup.

The command to start the terminal session in a terminal window is "tn5250 <ip-server>". The command works, but I cannot get the system to autostart this program after logging in.
I've tried autostart and keep me up, but nothing happens.
Does anyone have an idea what can be wrong?
Reply
19-05-2015, 09:29 AM, (This post was last modified: 19-05-2015, 09:30 AM by admin.)
#2
RE: Terminal session on startup
If you use RPiTC1 you have to modify the autostart script:
/home/rpitc/.config/lxsession/LXDE/autostart
by adding at the end of the file: @/usr/bin/tn5250 <ip-server>

For RPiTC2 you have to add a new autostart script in the Settings, Session and startup, application autostart. In the command field put /usr/bin/tn5250 <ip-server>
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)