Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PiFace Real Time Clock Issue
26-05-2015, 05:38 AM,
PiFace Real Time Clock Issue
Hi There,

Just wanted to know if anyone has managed to get the PiFace real time clock to work using RPiTC2 v1.1

I can confirm it works on the raspbian distro. But when I run and install the script from github it seems to miss a module. I think from memory its i2c_bcm2708.

Any thoughts on what I could do to try and resolve the issue?
28-05-2015, 11:37 AM,
RE: PiFace Real Time Clock Issue
remove the file: /etc/modprobe.d/rpitc-blacklist.conf
(blacklisting the i2c-bcm2708 and spi-bcm2708 module on startup)
30-05-2015, 08:34 AM,
RE: PiFace Real Time Clock Issue
Thanks. I'll give it a whirl when I have some time. I'll report back asap with my findings.
31-05-2015, 11:02 AM, (This post was last modified: 31-05-2015, 11:33 AM by keen4listerine.)
RE: PiFace Real Time Clock Issue
I re-imaged the SD card. Removed the blacklist.conf file.
Rebooted the device. Ran the install script.

When I type lsmod both modules i2c_dev and i2c_bcm2708 show. So that works fine.

When I attempt to see the hardware clock by the command "hwclock -r" I get the below error
hwclock: Cannot access the Hardware Clock via any known method.
hwclock: Use the --debug option to see the details of our search for an access method.

I use the command "sudo hwclock --debug" and get the following below.
hwclock from util-linux 2.25.2
hwclock: cannot open /dev/rtc: No such file or directory
No usable clock interface found.
hwclock: Cannot access the Hardware Clock via any known method.

So I check to see if the device is detected. I use the command "sudo i2cdetect 1" and get the below error.
Error: Could not open file `/dev/i2c-1' or `/dev/i2c/1': No such file or directory

I've been searching online and found a few forums on it. Could there be further work that needs to be done? See post #8.

Could this be an issue with this being used in a Rapsberry Pi 2 board?
07-06-2015, 11:56 AM,
RE: PiFace Real Time Clock Issue
OK So I've managed to suss this one out. I've included some steps incase anyone else out there is having issues.

sudo rm /etc/modprobe.d/rpitc-blacklist.conf
sudo nano /etc/modules

Ensure that the below modules are added

sudo nano /boot/config.txt

Add add the bottom


chmod +x
sudo ./
sudo reboot
sudo date -s "02 JUN 2015 22:20:30"
sudo hwclock -w
sudo hwclock -r
sudo -s
hwclock -w
hwclock -r

Unplug the network cable

sudo reboot

Test and ensure the hardware clock is now working. Should be all good.

Also I did notice if you plug the PiFace RTC Shim in to the incorrect GPIO headers it short circuits the battery. This then acts as if you were to remove the battery from the device. Hence the clock resets.

Thanks to Admin for helping me out and everyone else who has worked and helped on this project.

Forum Jump:

Users browsing this thread: 1 Guest(s)