Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
clean RPi-TC only rdp
09-06-2015, 09:52 AM,
#1
clean RPi-TC only rdp
Hey guys, I'm new here, and first of all I need to tell you, that you are amazing. Great work really!

I have a question. I want run only freerdp client and nothing else. So I want to delete other programs, menus, wallpapers plug-in for date and time.. so I want just one desktop short-cut for freerdp and nothing else. I tried some modifications, but I couldn't get right results. I would be really happy if I can get your advice and help.

Thank you very much!
Reply
29-08-2015, 03:46 PM,
#2
RE: clean RPi-TC only rdp
I was able to create something similar to this by doing the following:
  • Unchecking Docky and Conky in the autostart settings
  • Creating desktop icon for xFreeRDP connection by copying from /usr/share/applications/xfreerdp.desktop to /home/rpitc/Desktop/ and then showing desktop icons by going into Settings>Desktop>Icons and change from Minimized Applications to File/Launcher Icons

In this method the other applications are still there but I think you could effectively hide them by disabling the right-click menu.
Reply
02-09-2015, 06:08 PM, (This post was last modified: 02-09-2015, 06:09 PM by greavette.)
#3
RE: clean RPi-TC only rdp
I'm a little late in replying to this thread but I'll add my two cents in case the OP comes back or if anyone else stumbles upon this question and is in a similar situation...

In addition to the excellent advice provided by Douglas Riddle, I would also point you to Gibbio's RDP Gui - http://rpitc.blogspot.ca/2013/09/freerdp...lient.html. Don't let the age of this tool fool you into thinking it's not still usable. I've been using this tool since it first was created (for two years now) for some of our users in our office. In my opinion RDP Gui gives a very professional look to our thin clients so users can login with a GUI instead of clicking on a shortcut. Of course opinions vary about what looks professional so if you prefer just a desktop shortcut then do what works for you. Wink

RDP Gui has a config file (rdpgui.ini) whereby you can specify either rdesktop or freerdp connections. You can list mulitple computernames in the dropdown as well if that is required. I start RDP Gui at startup and it's there on the desktop waiting for someone to login.

Give it a try...you can easily turn it off it you don't like it.
Reply
02-09-2015, 08:32 PM,
#4
RE: clean RPi-TC only rdp
Better late than never. I'm hijacking the thread a bit here, but I think RDPGUI might solve my issue that I need NLA disabled in order to show the login screen. I have downloaded, copied, and configured RDPGUI per the guide but am having problems getting it to work, which I'm guessing is related to python-qt4. Is there any guide to how to install python-qt4?

source: RDPGUI
Reply
02-09-2015, 09:39 PM,
#5
RE: clean RPi-TC only rdp
sure...give this a try:

Code:
apt-get update
apt-get install python-qt4

That should get qt4 installed for you (just checked it myself on a new version of rpitc to confirm).

Once you've copied all the files into your /usr/bin folder use your starup menu to point to /usr/bin/rdpgui.py to auto start this tool at startup.

Let me know if you have any issues.
Reply
02-09-2015, 10:56 PM,
#6
RE: clean RPi-TC only rdp
That was what I needed, thank you! I now have the login window popping up prompting for username and password. I did discover a new issue though ... xFreeRDP does not authenticate when the user is a member of Windows' "Protected User" group. Shouldn't be a problem for normal domain users though. Thanks again!
Reply
02-09-2015, 11:01 PM,
#7
RE: clean RPi-TC only rdp
Glad to hear you are up and running with RDP Gui. Smile
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)