Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
static IP on v5
19-03-2014, 07:36 AM,
#1
static IP on v5
Hello,
I have been trying for some time to get a static IP address running on my TC version 5, but have not been able to do so.

I have tried the following inside /etc/network/interfaces :

auto lo
iface lo inet loopback
#auto eth0
#iface eth0 inet static
address 10.3.99.8
netmask 255.255.255.0
network 10.3.99.0
broadcast 10.3.99.255
gateway 10.3.99.1


forgive me if the solution is staring me right in the face as I am still new to programming.

If someone could point me in the right direction it would be great, thanks!
Reply
20-03-2014, 02:44 PM,
#2
RE: static IP on v5
Remove the remark brackets on line 3 & 4
I'm a N00b, on so many levels...Huh
Reply
20-03-2014, 09:42 PM,
#3
RE: static IP on v5
Unfortunately when I take away the # on the auto eth0 and try to restart the network it fails,
That when I try to use ifconfig and check it is using eth1, but when I try to change everything to eth1 I get an "RTNETLINK : file already exists" error.

It seems I can't assign a static to eth0 or eth1 as this setup stands.

My ultimate goal is to connect to set static to 10.3.99.27 and connect to ip 10.3.99.8 only and have gateway of 0.0.0.0
Reply
21-03-2014, 09:10 AM,
#4
RE: static IP on v5
This is my interfaces file, and it works with static IP.

auto lo

iface lo inet loopback
iface eth0 inet static
address 192.168.0.10
netmask 255.255.255.0
gateway 192.168.0.1
dns-domain mydomain.se
dns-nameservers 192.168.0.9 192.168.0.20 8.8.8.8
allow-hotplug wlan0
iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp
I'm a N00b, on so many levels...Huh
Reply
28-04-2014, 08:42 AM,
#5
RE: static IP on v5
(21-03-2014, 09:10 AM)ricande Wrote: This is my interfaces file, and it works with static IP.

auto lo

iface lo inet loopback
iface eth0 inet static
address 192.168.0.10
netmask 255.255.255.0
gateway 192.168.0.1
dns-domain mydomain.se
dns-nameservers 192.168.0.9 192.168.0.20 8.8.8.8
allow-hotplug wlan0
iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp
Sorry that don't work.
Is where a chance to change the settings. I don't want the raspberry in my DHCP-network.
Reply
02-05-2014, 10:06 PM,
#6
RE: static IP on v5
Use the below and replace ip ranges as needed

sudo nano /etc/network/interfaces

Remove the line that reads

iface eth0 inet dhcp

Add the following

iface eth0 inet static
address 192.168.0.6
netmask 255.255.255.0
network 192.168.0.0
broadcast 192.168.0.255
gateway 192.168.0.1
Reply
21-10-2014, 07:59 PM,
#7
RE: static IP on v5
This is once again causing problems on the new rpi-tc X

After setting the static address in /etc/network/interfaces do I need to reset the Ethernet on the pi?

I have it set as:

iface eth0 inet static
address 10.3.99.32
netmask 255.255.255.0
network 10.3.99.0
broadcast 10.3.99.254
gateway 10.3.99.1
Reply
21-10-2014, 08:22 PM,
#8
RE: static IP on v5
modify the interfaces (sudo nano /etc/network/interfaces) file:

auto lo
iface lo inet loopback
#auto eth0
#iface eth0 inet dhcp
iface eth0 inet static
address 10.3.99.32
netmask 255.255.255.0
network 10.3.99.0
broadcast 10.3.99.254
gateway 10.3.99.1


then reboot
Reply
22-10-2014, 04:07 AM,
#9
RE: static IP on v5
i will try this, thank you very much!!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)