Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
No sound through 3.5mm jack
03-03-2017, 02:55 PM,
No sound through 3.5mm jack

I've configured a Rasberry Pi 3 RPITC using XfreeRDP to connect to a Windows 2012 server. When booting my RPITC, it automaticly shows a FreeRDP/RDesktop GUI client ( and I only have to fill in my username and password and the RDS-session is started. Great!

Only one issue I just can't fix. When I plug in a headphone in the 3,5mm mini jack it just won't play any audio. Still I can see, when I click on the audio picto in the right bottom of my RDS session, that audio is playing. I searched all over and found some settings which I tried in my 'rdpgui.ini' file.

I have used this line:

RDPDefaultFlags = /cert-ignore /sound:sys:pulse /f /drive:USB0,mnt/usb

The sound-part is "/sound:sys:pulse"

After some searching I added: /audio-mode:0

But still no sound. Maybe it is trying to put the sound thriugh HDMI, but I cant find a way to make te sound go through the mini jack.

Can someone help me with this?

06-03-2017, 12:58 PM,
RE: No sound through 3.5mm jack
In the right click menu there is a Sound selector script thats allow you to change the audio output. I think the default is HDMI. Just run the script and select the mic out.

Or, you can modify the config.txt file in the /boot/ partition to force the audio output... but I didnt remember the exact string.
06-03-2017, 05:08 PM,
RE: No sound through 3.5mm jack
Thanks for your reply. I tried some settings but no luck, I tried a whole clean install, and I used the right click menu. I selected RPiTC Config -> Audio Output Device Selector. A window opens with 'RPiTC2 Audio output chooser' There is HDMI, Jack or Auto. Auto is already selected. I selected Jack and did OK. An information Window comes up that says: "Audio output changed to: Jack". So now I make a XfreeRDP connection, and remote I surf to youtube and start a video. I see de video, I hear some hiss, a few seconds of sound and then total silence. When I try to disconnect my RDS connection the Raspberry hangs. I have to reboot.
After reboot, I go to the audio ouptput selector again. Auto is selected, ik just selected OK. I get the message that Audio output is changed to: auto. I try again. I connect to Windows 2012 server, I start a youtube video. Still no audio, and again the Rasberry hangs when I disconnect the RDS session.
So no luck sadly.

Now, I tried selecting 'Multimedia' -> PulseAudio Volume Control.

The volume was at 0%, so I made volume 80% on the tab 'Output Devices' At the tab 'Playback' I also selected 80%

Again, I tested, and now I hear sound when I start the youtube video but after a few seconds the sound is gone. Total silence. I tried a few times and it can take 10 seconds, one time a whole minute but then the sound is gone. And still the Rsapberry Hangs when I disconnect.

Seems to be some kind of driver thing or maybe some hidden setting. Any ideas?
06-03-2017, 06:12 PM,
RE: No sound through 3.5mm jack
If you try to play just an audio file (wav or mp3 with windows media player or vlc) did you have the same issue?
06-03-2017, 06:51 PM,
RE: No sound through 3.5mm jack
Yes sadly, when I start mediaplayer by clicking on a mp3, I hear 5 seconds of music, and then silence. The music is still running though. When I click on the sound icon in the right bottom of my RDS desktop I can see the volume level variating. So there is sound, but I'm not hearing it, and of course the Raspberry hangs when I disconnect. And strangely, if I do not try to play a sound file, it disconnects without a problem. Somehow playing sound makes it all very unstable.
07-03-2017, 09:43 AM,
RE: No sound through 3.5mm jack
Did you try the dFreeRDP too? The FrameBuffer accelerated RDP is working better with audio/video redirection.
Same setup as the xFreeRDP plus, you need to setup the framebuffer/depth parameters in /boot/config.txt and in /etc/directfbrc to match your screen resolution/depth
07-03-2017, 01:32 PM,
RE: No sound through 3.5mm jack
I have the same issues with the 3_1.12 release. With the previous it was possible to have good sound (at least for sound-files) with /soundConfusedys:alsa and run xfreerdp as root. Even video did work acceptable (what I do not need). The whole line looked like:
sudo xfreerdp_git TServer /cert-ignore /f /soundConfusedys:alsa +fonts +aero /smartcard +drives +clipboard /rfx /smart-sizing /gdiConfusedw /jpeg /jpeg-quality:100 /codec-cache:jpeg +async-update

With the 3_1.12 release sound is buggy.
07-03-2017, 01:37 PM,
RE: No sound through 3.5mm jack
I did not try out dFreeRDP, but I'm willing to do so but I'm strugling now to get it working. I think I'll try again from a complete new install. It's hard to get it exactly te way it should be. "Failure in SSL library" and "NTLMSSP implementation may be to blame" But I'm not giving up, when I get it working I'll let you now if it works better.
Thanks a lot for your help.
07-03-2017, 04:27 PM, (This post was last modified: 07-03-2017, 05:18 PM by Henk Jaspers.)
RE: No sound through 3.5mm jack
This is very frustrating. I can make a RDS connection using this line:

xfreerdp /v:<RDS-SERVER-ADDRESS> /sound:sys:pulse /no-certificate /u:<username> /p:<password> <RDS-SERVER-ADDRESS>

The RDS connection is made, I see my remote desktop, but when I play a mp3 the sounds dissapears in 3 seconds, and I can't disconnect anymore.

So, following advice, in the builder I selected dFreeRDP (RPi-TC Build), after that I ran

Then I edited /boot/config.txt and I removed the commentsigns that were in front of "framebuffer" so width=1920, height=1080 and depth=16.

So now I tried to connect through dfreerdp using this line:

dfreerdp /v:<RDS-SERVER-ADDRESS> /sound:sys:pulse /no-certificate /u:<username> /p:<password> <RDS-SERVER-ADDRESS>

But no go.

After I press ENTER it states:

transport_connect: getaddrinfo (Temporary failure in name resolution)
Error: protocol security negotiation failure

I tried XfreeRDP again with altering sound-settings, latency times, but still no success.

I Tried it with version 3.11, to see if it makes any difference but no, same issue.

I'd love to try dfreerdp if I can get it running. Do you have any advice?

08-03-2017, 09:58 AM, (This post was last modified: 08-03-2017, 10:00 AM by admin.)
RE: No sound through 3.5mm jack
try this cmdline (as root) for dfreerdp:
dfreerdp --no-tls --no-nla -f -g 1920x1080 --fonts -x 0x80 -x l --disable-full-window-drag --composition --gdi hw --plugin rdpsnd --data alsa --data disk:usbdisk:/media/ -- server.domain.lan

dFreeRDP use the old style freerdp command line mode.

Forum Jump:

Users browsing this thread: 1 Guest(s)