Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
xfreerdp authentication error???
22-04-2014, 05:08 PM, (This post was last modified: 22-04-2014, 05:44 PM by borgy95.)
xfreerdp authentication error???

I'm setting up my fifth Rpi using this distro - First off thanks it's a great distro!
Each Pi i have is basically exactly same each connects to a terminal server and serves up a notice board display.

For all intents and purposes this is an exact clone. Just a different IP/hostname and the user logging into the terminal server is unique. Password is the same as other 4. So I would've expected it to act exactly the same.

However on this Pi when I connect with:
xfreerdp /v:10.14.XXX.XX /size:1024x798 /u:CRX-display /p:xxxxxxxxx

I get the following response:

connected to
SSL_read: Failure in SSL Library (protocol error?)
SSL_read: error:14094419 routines:SSL3_READ_BYTES:tlsv1 alert access denied credssp_recv() error: -1
Authentication failure, check credentials.
if credentials are valid, the NTLMSSLP implementation may be to blame.
Error: protocol security negotiation or connection failure

Is this a known error?

I am using RPi-TC_ARMv6j_R4 - using the later versions meant my RPi failed to boot. It is a fresh image that has had nothing else done to it.
I have checked the password and reset it to be sure. I have definitely provided remote session privileges to the user. I have tested trying an RDP session from another PC and it has worked.

Any ideas, how to fix this issue?


(edited for grammatical errors)

Fixed the issue stumbling on some posts on github.

The link is (with more information @
I found the solution in post #8 add the -sec-nla switch.
Doing this 'I think' means you bypass authentication and connect anyway then are prompted for credentials on the windows login screen rather that xfreerdp passing it through.
As to why i have to do this on this machine and not the other 4RPi's i don't know.

Disabling NLA is also recommended. and seemed to fix some peoples problems. In my case it was already disabled.
Hope that helps someone sometime.
02-05-2014, 10:38 PM,
RE: xfreerdp authentication error???
thanks for posting your findings, it helps.. I would make on helpful suggestion,, try to remember you know your set up better then anyone. but for us to help a little more info we may be more helpful to you.. see you view and I think you'll see why I say that.. if you can give me more information on your over all system I maybe able to help..

How many Client (pi) are you connection at one time
what is your Host system
are you "local" or "remote"
have you tried to restart all device (master first then guests)
Big Grin
22-05-2014, 10:11 PM,
RE: xfreerdp authentication error???
Is there a reason not to use
/sec:rdp /cert-ignore

Forum Jump:

Users browsing this thread: 1 Guest(s)