Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Using Thinclient with Win SBS 2003
23-05-2014, 11:23 PM,
#11
RE: Using Thinclient with Win SBS 2003
(23-05-2014, 10:40 PM)greavette Wrote: I'm from Canada eh. Smile

You are correct, I remove all other shortcuts from my rpitc and have only the rdp-gui and conky details left. Looks very clean in my opinion.

Ok Dennis, let's get you going with installing RDP-Gui in your test lab at home.

From your rpitc terminal update your repos using this instruction:
sudo apt-get update

You can if you like do an upgrade of all code as well using sudo apt-get upgrade but you don't need to at this time. But at some point it's a good idea to update all apps.

Now install python-qt4
sudo apt-get install python-qt4

Now go here and download the zip file for rdp-gui. I did the download and transfer of files from a Windows PC to my Raspberry Pi via winscp.
https://github.com/Gibbio/RDPGUI

Unzip it and transfer all files to your /home/rpitc/ folder. I created a tmp folder and dumped them all there.

Now login to your pi thin client and open the terminal (or if you are still on Windows with the transfer of these files, open putty and do the following) and navigate to where you transferred the files too. Copy all the files to the /usr/bin/ folder:

sudo cp rdp* /usr/bin/
sudo cp *.png /usr/bin/

The above commands will copy all the important bits to the /usr/bin folder.

Still using your terminal change directory go to your /usr/bin/ folder:

cd /usr/bin/

And edit your rdpgui.ini file:

sudo nano rdpgui.ini

Nano will allow you edit the contents of this file (sorry if you already know this, but I just want to be thorough with my instructions in case you don't know...or if anyone else happens by this post and needs assistance).

Adjust the settings in this file to use rdesktop. Mine looks as follows (with some of the important details left out of course):

[DEFAULT]
RDPBinary = rdesktop
RDPDomain = swdomain
RDPServer = Server1 Workstation1 192.168.3.198
RDPDomainFlags = "-d"
RDPServerFlags = ""
RDPUserFlags = "-u"
RDPPasswordFlags = "-p"
RDPDefaulfFlags = "-x l -f"
RDPExtraFlags = "-z"

The details of how to setup the .ini file can be found here:
https://github.com/Gibbio/RDPGUI

In my instructions I'm not passing sound to my windows virtual machine. Make sure you have -z for compression and -f for fullscreen (unless you don't want fullscreen that is). If you don't have a domain then remove the -d option and leave the RDPDOMAIN blank.
You will also notice that the Server field is actually a drop down menu. In my file above I'm using my DNS names in our office to allow the user to connect to either Server1 or Workstation1 or IP 192.168.3.198 (not the real DNS names or IP in my office by the way. Smile ). Anyway, if you want to have people have a choice of which server/workstation to connect to, leave a space between each DNS or IP you input into this field. Or you can put only one server name/ip if you like if you don't want them to have the choice.

Now save your rdpgui.ini file by pressing <ctrl> x and select y to save.

To make sure you don't have problems I Looked at the rdpgui.py code and that issue I mentioned appears to be fixed now with the missing quotes so you should be good to go.

Now from the terminal you can edit your autostart file:
nano /home/rpitc/.config/lxsession/LXDE/autostart

Or you can right click on your rpitc desktop and edit the same autostart file. Add in the call to start the rdp-gui app. I added it just after the other commented out apps. My autostart looks as follows:

#@virt-viewer
#@x2goclient
@python /usr/bin/rdpgui.py
######################################################

Save the file and reboot your rpitc. Now when you login you will see the rdp-gui app on your desktop. You can't move it...it's embedded on the desktop and will stay there.

Login to the Windows machine with your login credentials and clickety-click You're remote connecting to your machine via this amazing rpitc O/S Gibbio has built for us!

I can't wait to get started on this...probably will very late this evening I have to get dinner together for the kids right now...and then bedtimes. Thank you so much for the step by step...Everything is so much clearer now! BTW, I love Canada...that is where I am headed whn our country collapses - lol...to the Boreal forest...live off the grid like stoneage. lol
Reply


Messages In This Thread
Using Thinclient with Win SBS 2003 - by dbirk007 - 22-05-2014, 10:35 PM
RE: Using Thinclient with Win SBS 2003 - by dbirk007 - 23-05-2014, 11:23 PM

Forum Jump:


Users browsing this thread: 1 Guest(s)