Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Using Thinclient with Win SBS 2003
03-06-2014, 09:17 PM,
#18
RE: Using Thinclient with Win SBS 2003
(03-06-2014, 05:35 PM)dbirk007 Wrote:
(29-05-2014, 04:33 PM)greavette Wrote: It would appear you already had rdpgui installed on this image. I'm not using the latest rpitc at the moment so I can't check, but let's try something. On your Desktop right click and go to your Openbox context menu. In the folder RPi-TC Apps do you see RDPGUI? If you do then it was already installed. Simply left click RDPGui and it you should see the GUI start for you.

The .ini file looks good to me. yes, put in the name of the domain the userid needs to connect to the workstation. You can use the IP address or the DNS name, either works. When you fire up the RDPGui you should now see the Domain as PStevens and in the dropdown for Server you should see 192.168.3.198.

Once you've done a test and started RDPGui, you should be able to load it at startup too. If it's already installed on your image (which I suspect it is) then you should be able to start it on boot. Again right click on your Desktop and this time go the folder called Configuration. Select 'Change Autostart Applications'. Leafpad (text editor) will open showing you things that are done when your computers starts. Tell me if you see a line that says @python /usr/bin/rdpgui.py. It may have a # sign in front of it. If you see that line, remove the # sign. exit the autostart file (saving it). Now reboot your Pi. When it starts you should see the RDPGui on your desktop.

Let me know how it goes.

As for your question about copying, here's the scoop...

When copying files you have to either be specific with the location you are copying from (put in the full path):
Code:
sudo cp /home/rpitc/tmp/rdp* /usr/bin/

or change directory into the tmp folder first and give the copy instruction:

Code:
cd /home/rpitc/tmp/
sudo cp rdp* /usr/bin/

It's no different than using DOS or Powershell in windows. You have to be specific on where the files are you are copying from.

I'm not sure what folder your terminal was in when you tried to copy the files but the fact it came up with an error on copying probably means the folder you were in didn't have the rdp files. Smile

As for copying files in Linux...you need to make sure you have the right privileges to copy the file to certain folders. Did you use the file browser to copy and paste the files. That may work, but I prefer to use the terminal. If you don't put sudo in front of the copy (cp) instruction and you need elevated privileges to copy the file(s), the terminal will tell you and you can simply input the instruction again prefaced by sudo. Doing it from the file browser (unless you've started the file browser with root privileges) may not work.

I'm thinking you already had RDPGui installed on this image. If you did then you may want to start over and re-image your card (after confirming RDPGui is working and all) and start with a fresh image and this time don't download and unzip RDPGui and copy to /usr/bin/. Probably nothing is wrong with overwriting the files like you did but you might as well leave what Gibbio has done for you alone if it works. It's up to you (not sure how much modification you've done).

Hope this explanation helps!

Charles,

Thank you so much again! Sory I am late to respond. I had a complete HDD crash on my primary PC. I am on an old laptop right now...feel like a caveman - lol. Luckily I was able to clone the drive before complete failure and I should have the new drive to reimage today in the mail. Anyway, I think you are right...since it asked me if I wanted to copy/replace all files in that folder, it looks like RDPgui was already installed. However, on the latest release (the one I installed) it is not on the notes. Now, I think I should just reformat and reimage and start all over.

Everything "looks" okay, and the login screen is there when I boot into the RPI-tc, but I am worried something may have went wrong. Maybe I should just re-do it after all. I don't want to get to the office I am setting this up in and look inept, you know?

I did use the very latest release though...so maybe you are right. I will do it again, now that I (hopefully) have a better understanding on copying and moving files in command line in Linux. I am learning...and I love to learn!

Thank you so much! I think i will give it another shot today and see what happens.

Dennis

Craig,

You were correct, I reformatted and reimaged the SD and RDPGui is already included. That is all I need I guess to get this going! Awesome! I'll just remove the hash in the startup applications and add my data again to the config file! BTW, do I add the domain PStevens and the server IP - both? Also, once I open the RDPgui...how do I close that window...just in case I wanted to. Thanks a MILLION my friend!
Reply


Messages In This Thread
Using Thinclient with Win SBS 2003 - by dbirk007 - 22-05-2014, 10:35 PM
RE: Using Thinclient with Win SBS 2003 - by dbirk007 - 03-06-2014, 09:17 PM

Forum Jump:


Users browsing this thread: 1 Guest(s)